## Documentation Index

Fetch the complete documentation index at: [/llms.txt](https://docs.m3ter.com/llms.txt)

Use this file to discover all available pages before exploring further.

When you have built a query for your Usage, Billing, or Prepayments data in m3ter using a Data Explorer, you can export the data returned for the query as a `.csv` file. This topic explains how to export your query results data from the Data Explorers.

**Notes:**

- **Usage Data Explorer - example export**. The following procedure explains how to export _Usage_ data query results in the original version Usage Data Explorer. You can follow similar steps to export your _Billing_ or _Prepayments_ query results.
- **Usage Data Explorer (v2)**. If you’re working in Data Explorer (v2), you can export query results data directly from the Result rows table. See [Usage Data Explorer (v2)](https://docs.m3ter.com/guides/data-explorer/usage-data-explorer-v2) for details.

**To export query results:**

1. Select **Metering>Usage Data Explorer**.
2. In the **Usage query builder**, configure a query, perform the query, and review the returned data in the **Data Table** tab.
3. On the **Data table** tab, select **Export**. The returned data set is compiled in _.csv_ formatted file, downloaded, and saved locally.

**Warning: Number of Rows for Export!** If you download query results in a `.csv` formatted file, the number of rows is limited to **20001**.

**Tip: Exporting Prepayments Query Data?** If you’re exporting Prepayments query data, the **Export** button is on the **Prepayments - Table** tab.
